const regex = /(.{13}) +/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.{13}) +', 'g')
const str = `This is a test. The app should break this string in substring on whitespaces after 13 characters`;
const subst = `$1\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);