use strict;
my $str = 'This is a test. The app should break this string in substring on whitespaces after 13 characters';
my $regex = qr/(.{13}) +/p;
my $subst = '$1\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";