re = /(.{13}) +/
str = 'This is a test. The app should break this string in substring on whitespaces after 13 characters'
subst = '$1\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result