const regex = /^(0?[1-9]|1[012])(:[0-5]\d) [APap][mM]/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(0?[1-9]|1[012])(:[0-5]\\d) [APap][mM]', 'gmi')
const str = `10:12 PM
09:12 AM
12:00 am`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}