$re = '/^(0?[1-9]|1[012])(:[0-5]\d) [APap][mM]/mi';
$str = '10:12 PM
09:12 AM
12:00 am';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);