re = /^(0?[1-9]|1[012])(:[0-5]\d) [APap][mM]/mi
str = '10:12 PM
09:12 AM
12:00 am'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end