package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(0?[1-9]|1[012])(:[0-5]\d) [APap][mM]$`)
var str = `10:12 PM
09:12 AM
12:00 am`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}