// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^(0?[1-9]|1[012])(:[0-5]\d) [APap][mM]$").unwrap();
let string = "10:12 PM
09:12 AM
12:00 am";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}