import re
regex = re.compile(r"^(0?[1-9]|1[012])(:[0-5]\d) [APap][mM]$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("10:12 PM\n"
"09:12 AM\n"
"12:00 am")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")