# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(http|https):\/\//\1\2\L\3/g;t' <<< "<a href=\"/World/Spain\" title=\"Topics\">Spain</a>
<a href=\"$G_URL/World/Spain\" title=\"Spain\">Spain</a>
<a href=\"'.$G_URL.'/World/Spain\" title=\"Spain\">Spain</a>
<a href=\"http://dasdas/asdads/World/Spain\" title=\"Spain\">Spain</a>
<a href=\".$G_URL.'/World/Spain\" title=\"Spain\">Spain</a>"