$re = '/^(http|https):///';
$str = '<a href="/World/Spain" title="Topics">Spain</a>
<a href="$G_URL/World/Spain" title="Spain">Spain</a>
<a href="\'.$G_URL.\'/World/Spain" title="Spain">Spain</a>
<a href="http://dasdas/asdads/World/Spain" title="Spain">Spain</a>
<a href=".$G_URL.\'/World/Spain" title="Spain">Spain</a>';
$subst = "\1\2\L\3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;