// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(http|https)://").unwrap();
let string = "<a href=\"/World/Spain\" title=\"Topics\">Spain</a>
<a href=\"$G_URL/World/Spain\" title=\"Spain\">Spain</a>
<a href=\"'.$G_URL.'/World/Spain\" title=\"Spain\">Spain</a>
<a href=\"http://dasdas/asdads/World/Spain\" title=\"Spain\">Spain</a>
<a href=\".$G_URL.'/World/Spain\" title=\"Spain\">Spain</a>";
let substitution = "\\1\\2\\L\\3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}