const regex = /danger-radius_id_(.+)\s/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('danger-radius_id_(.+)\\s', '')
const str = `danger-radius danger-radius_id_id-pole_124 hidden`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}