re = /danger-radius_id_(.+)\s/
str = 'danger-radius danger-radius_id_id-pole_124 hidden'
# Print the match result
str.match(re) do |match|
puts match.to_s
end