$re = '/danger-radius_id_(.+)\s/';
$str = 'danger-radius danger-radius_id_id-pole_124 hidden';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);