package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`3001-001-003`)
var str = `IN123456/10-3001-001-003`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}