$re = '/3001-001-003/';
$str = 'IN123456/10-3001-001-003';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);