using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=""userId"":)\d+";
string input = @"{""errorId"":0,""errorLongDesc"":""Data Successfully saved"",""errorDesc"":""success"",""user"":{""userId"":3706}}";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}