const regex = /(?<="userId":)\d+/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<="userId":)\\d+', '')
const str = `{"errorId":0,"errorLongDesc":"Data Successfully saved","errorDesc":"success","user":{"userId":3706}}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}