re = /(?<="userId":)\d+/
str = '{"errorId":0,"errorLongDesc":"Data Successfully saved","errorDesc":"success","user":{"userId":3706}}'
# Print the match result
str.match(re) do |match|
puts match.to_s
end