$re = '/sourcetype=([a-z]+\-{1}\w+)/i';
$str = 'sourcetype=pmon-accesslog
sourceType=pmon access
sourceType=pmon_asdfkljaslkd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);