// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)sourcetype=([a-z]+\-{1}\w+)").unwrap();
let string = "sourcetype=pmon-accesslog
sourceType=pmon access
sourceType=pmon_asdfkljaslkd";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}