re = /sourcetype=([a-z]+\-{1}\w+)/i
str = 'sourcetype=pmon-accesslog
sourceType=pmon access
sourceType=pmon_asdfkljaslkd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end