#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "class[\s\S]*bar2\(\)(?!class)"
Local $sString = "class foo1(object):" & @CRLF & _
" bar1()" & @CRLF & _
"" & @CRLF & _
"class foo2(object):" & @CRLF & _
" bar2()" & @CRLF & _
"" & @CRLF & _
"class foo3(object):" & @CRLF & _
" bar3()"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")