import Foundation
let pattern = #"class[\s\S]*bar2\(\)(?!class)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
class foo1(object):
bar1()
class foo2(object):
bar2()
class foo3(object):
bar3()
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}