$re = '/class[\s\S]*bar2\(\)(?!class)/';
$str = 'class foo1(object):
bar1()
class foo2(object):
bar2()
class foo3(object):
bar3()';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);