package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[([^]]*)\]\(([^\s^\)]*)[\s\)]`)
var str = `[sample link](http://example.com/)
[sample link](http://example.com/ "with title")
[link name](http://stackoverflow.com/questions/40177342/regex-convert-a-markdown-inline-link-into-an-html-link-with-c-sharp "link to this question")`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}