re = /\[([^]]*)\]\(([^\s^\)]*)[\s\)]/
str = '[sample link](http://example.com/)
[sample link](http://example.com/ "with title")
[link name](http://stackoverflow.com/questions/40177342/regex-convert-a-markdown-inline-link-into-an-html-link-with-c-sharp "link to this question")'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end