using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[([^]]*)\]\(([^\s^\)]*)[\s\)]";
string input = @"[sample link](http://example.com/) some text [sample link](http://example.com/ ""with title"")
[link name](http://stackoverflow.com/questions/40177342/regex-convert-a-markdown-inline-link-into-an-html-link-with-c-sharp ""link to this question"")";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}