$re = '/\[([^]]*)\]\(([^\s^\)]*)[\s\)]/';
$str = '[sample link](http://example.com/) some text [sample link](http://example.com/ "with title")
[link name](http://stackoverflow.com/questions/40177342/regex-convert-a-markdown-inline-link-into-an-html-link-with-c-sharp "link to this question")';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);