import re
regex = re.compile(r"\[([^]]*)\]\(([^\s^\)]*)[\s\)]")
test_str = ("[sample link](http://example.com/) some text [sample link](http://example.com/ \"with title\")\n"
"[link name](http://stackoverflow.com/questions/40177342/regex-convert-a-markdown-inline-link-into-an-html-link-with-c-sharp \"link to this question\")")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")