const regex = new RegExp('https?://(?:www\\.|)([\\w.-]+).*', 'gm')
const str = `https://domen.site.ru/podsait/03285926/#2412747495
http://www.site.ru/site/24722305
http://www.domen.site.ru/site/247493215/site
site.ru`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);