use strict;
my $str = 'https://domen.site.ru/podsait/03285926/#2412747495
http://www.site.ru/site/24722305
http://www.domen.site.ru/site/247493215/site
site.ru';
my $regex = qr~https?://(?:www\.|)([\w.-]+).*~mp;
my $subst = '$1';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";