import re
regex = re.compile(r"https?://(?:www\.|)([\w.-]+).*", flags=re.MULTILINE)
test_str = ("https://domen.site.ru/podsait/03285926/#2412747495\n"
"http://www.site.ru/site/24722305\n"
"http://www.domen.site.ru/site/247493215/site\n"
"site.ru")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)