import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*([0-9]*\\.?[0-9]*)\\s+\\d{1,2}[\\W_]\\s+([0-9A-F]+[x]?)\\s+(?:Rx|Tx)\\s+(?:d)\\s([0-8])\\s?((?:[0-9A-F]{2}[ ]?){0,8})$";
final String string = " 476.068710 3 A1 Rx d 1 01 23 54";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}