// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^\s*([0-9]*\.?[0-9]*)\s+\d{1,2}[\W_]\s+([0-9A-F]+[x]?)\s+(?:Rx|Tx)\s+(?:d)\s([0-8])\s?((?:[0-9A-F]{2}[ ]?){0,8})$").unwrap();
let string = " 476.068710 3 A1 Rx d 1 01 23 54";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}