import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*?(?=-|_)";
final String string = "Sec_GHTY_WE\n"
+ "NewSec_JOL_ru\n"
+ "Sec-KIH-YRK\n"
+ "Sec_PWq-FTF\n"
+ "NewSec-LPO-WE";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}