import re
regex = re.compile(r"^.*?(?=-|_)", flags=re.MULTILINE)
test_str = ("Sec_GHTY_WE\n"
"NewSec_JOL_ru\n"
"Sec-KIH-YRK\n"
"Sec_PWq-FTF\n"
"NewSec-LPO-WE")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")