re = /^.*?(?=-|_)/m
str = 'Sec_GHTY_WE
NewSec_JOL_ru
Sec-KIH-YRK
Sec_PWq-FTF
NewSec-LPO-WE'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end