using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^..";
string input = @"c1c425268e68385d1ab5074c17a94f14";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}