$re = '~^..~m';
$str = 'c1c425268e68385d1ab5074c17a94f14';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);