package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^..`)
var str = `c1c425268e68385d1ab5074c17a94f14`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}