# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<[pP]-([a-zA-Z-]+)([^>]*)?>[\s\n]*<\\/[pP]-\1>/<p-$1$2\/>/mg;t' <<< "<p-button type=\"submit\" [outlined]=\"true\" label=\"FILTRAR\" icon=\"pi pi-search\"[outlined]=\"true\" [outlined]=\"true\">
</p-button>
<p-button[outlinued]=\"true\"></p-gfwefew>
<p-button/>
<p-input pInputNumber></p-input>
<p-button
[outlinued]=\"true\"></p-button>
<p-button [outlinued]=\"true\" label=\"FILTRAR\" icon=\"pi pi-search\"></p-button>
<p-calendar [outlinued]=\"true\" label=\"FILTRAR\" icon=\"pi pi-search\"></p-calendar>
<p-button></p-button>
<p-BUTTON [outlined]=\"true\"
label=\"FILTRAR\"
icon=\"pi pi-search\">
</p-BUTTON>
<p-autoComplete id=\"populationCategoriesID\" formControlName=\"populationCategoriesID\"
[suggestions]=\"filtered['populationCategory']\"
(completeMethod)=\"filterMutiple($event,'populationCategory')\" field=\"name\" [multiple]=\"true\"
[showEmptyMessage]=\"true\">
</p-autoComplete>
"