const regex = /<[pP]-([a-zA-Z-]+)([^>]*)?>[\s\n]*<\/[pP]-\1>/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<[pP]-([a-zA-Z-]+)([^>]*)?>[\\s\\n]*<\\\/[pP]-\\1>', 'mg')
const str = `<p-button type="submit" [outlined]="true" label="FILTRAR" icon="pi pi-search"[outlined]="true" [outlined]="true">
</p-button>
<p-button[outlinued]="true"></p-gfwefew>
<p-button/>
<p-input pInputNumber></p-input>
<p-button
[outlinued]="true"></p-button>
<p-button [outlinued]="true" label="FILTRAR" icon="pi pi-search"></p-button>
<p-calendar [outlinued]="true" label="FILTRAR" icon="pi pi-search"></p-calendar>
<p-button></p-button>
<p-BUTTON [outlined]="true"
label="FILTRAR"
icon="pi pi-search">
</p-BUTTON>
<p-autoComplete id="populationCategoriesID" formControlName="populationCategoriesID"
[suggestions]="filtered['populationCategory']"
(completeMethod)="filterMutiple(\$event,'populationCategory')" field="name" [multiple]="true"
[showEmptyMessage]="true">
</p-autoComplete>
`;
const subst = `<p-$1$2/>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);