use strict;
my $str = '<p-button type="submit" [outlined]="true" label="FILTRAR" icon="pi pi-search"[outlined]="true" [outlined]="true">
</p-button>
<p-button[outlinued]="true"></p-gfwefew>
<p-button/>
<p-input pInputNumber></p-input>
<p-button
[outlinued]="true"></p-button>
<p-button [outlinued]="true" label="FILTRAR" icon="pi pi-search"></p-button>
<p-calendar [outlinued]="true" label="FILTRAR" icon="pi pi-search"></p-calendar>
<p-button></p-button>
<p-BUTTON [outlined]="true"
label="FILTRAR"
icon="pi pi-search">
</p-BUTTON>
<p-autoComplete id="populationCategoriesID" formControlName="populationCategoriesID"
[suggestions]="filtered[\'populationCategory\']"
(completeMethod)="filterMutiple($event,\'populationCategory\')" field="name" [multiple]="true"
[showEmptyMessage]="true">
</p-autoComplete>
';
my $regex = qr/<[pP]-([a-zA-Z-]+)([^>]*)?>[\s\n]*<\/[pP]-\1>/mp;
my $subst = '<p-$1$2/>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";