#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)^(?:foo|bar) (?!.*?['.-]{2})(?:[a-z\d'.-]{1,7} ){1,5}\w{1,7}$"
Local $sString = "foo Brian M. O'Dan Darwin" & @CRLF & _
"" & @CRLF & _
"foo Brian M.. ODan Darwin" & @CRLF & _
"foo Brian M. O'-Dan Darwin" & @CRLF & _
"foo Brian M. O'Dan Darwin"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")