import Foundation
let pattern = #"(?i)^(?:foo|bar) (?!.*?['.-]{2})(?:[a-z\d'.-]{1,7} ){1,5}\w{1,7}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
foo Brian M. O'Dan Darwin
foo Brian M.. ODan Darwin
foo Brian M. O'-Dan Darwin
foo Brian M. O'Dan Darwin
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)