use strict;
my $str = 'foo Brian M. O\'Dan Darwin
foo Brian M.. ODan Darwin
foo Brian M. O\'-Dan Darwin
foo Brian M. O\'Dan Darwin';
my $regex = qr/(?i)^(?:foo|bar) (?!.*?['.-]{2})(?:[a-z\d'.-]{1,7} ){1,5}\w{1,7}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}