using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=(?<!@)(?:@@)*)@([^\s@]*)$";
string substitution = @"$1";
string input = @"test
@test
@test aux
@test @aux
@test @@aux
@test @@@aux
@test @@@@aux
@test @@@@@aux";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}