import re
regex = re.compile(r"(?<=(?<!@)(?:@@)*)@([^\s@]*)$", flags=re.MULTILINE)
test_str = ("test\n"
"@test\n"
"@test aux\n"
"@test @aux\n"
"@test @@aux\n"
"@test @@@aux\n"
"@test @@@@aux\n"
"@test @@@@@aux")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)